Windows installation issue

I want to install igraph module at anaconda 3,8 on Windows system. But GraphML support is disabled, I cannot read GraphML file. So I decided to compile igraph package following the instructions on how to compile from source on Windows( Everything goes well until " Open the MSYS2 shell, enter this folder and run python build_c_core". After running the command, I got some errors which show “Could not compile the C core of igraph”. Hope you can help with this problem, thanks.

@vtraag Is GraphML support supposed to be disabled in the Anaconda Python package?

@Zhou_Ze It looks like you have not only GNU make but some other version of make in your PATH and this other version of make is shadowing GNU make. Can you please check whether you indeed have GNU make by running make -v? It should say “GNU make <some version number>”.

Yes, I believe that is also the case for the provided binary wheels from PyPI. We should still get that working, but at the moment it requires quite some changes, and I have not managed to get it working yet. For Anaconda we could use the provided libxml2. It should be significantly easier once we have switched to Cmake.

Edit: this only concerns Windows, not any other platforms.

Thanks for your reply. When I run ‘make -v’ on MSYS2, it said there is no this command. So I install it manually via ‘pacman -S make’. Again, I go to the python-igraph folder and run “python build_c_core”. Then, it shows some UnicodeDecodeError in the following picture:

What version of Python are you running (inside msys)? i.e. simply run python -v.

Note that we are happy to talk you through compiling igraph on Windows, but the desired goal of enabling GraphML is not attainable at the moment. There is a reason it is disabled, namely that we couldn’t get it to work with the current build system and provided binaries of libxml2. We are working on changing the build system, which should also make it possible to enable GraphML support.

3 posts were split to a new topic: Installation of igraph under cygwin

4 posts were merged into an existing topic: Installation of igraph under cygwin