R installation fails on Ubuntu 22.04

This is the error message I get when the installation exits:

Error: package or namespace load failed for ‘igraph’ in dyn.load(file, DLLpath = DLLpath, …):
unable to load shared object ‘/home/richard/R/x86_64-pc-linux-gnu-library/4.2/00LOCK-igraph/00new/igraph/libs/igraph.so’:
libmkl_rt.so.1: cannot open shared object file: No such file or directory
Error: loading failed
Execution halted
ERROR: loading failed

  • removing ‘/home/richard/R/x86_64-pc-linux-gnu-library/4.2/igraph’
  • restoring previous ‘/home/richard/R/x86_64-pc-linux-gnu-library/4.2/igraph’
    Warning in install.packages :
    installation of package ‘igraph’ had non-zero exit status

Any help would be appreciated.



Do you have Anaconda installed? If so, deactivate any conda environments before compiling any software, including igraph.

Please see here:

If you don’t have Anaconda installed, can you identify why you have MKL binaries in your path?

I do have miniconda installed. I deactivated conda in the R Studio terminal, then tried install.packages(“igraph”) in the R studio console. I was given the same error message. Was this the proper course of action to take?

I suggest trying the following in a newly opened terminal (not in RStudio):

Let us know if this worked.

Note that this likely won’t have any effect on your R session. It only affects that one terminal window, but not the R console within RStudio. This is why above I suggested not using RStudio at all.

It installed successfully. Thank you so much for the help.