Naming Conventions of Similar Functions

I’m very new to igraph and came from using networkX. I found the naming conventions for the shortest path functions to be lacking in clarity. I misunderstood the differences between shortest_paths , get_shortest_paths and get_all_shortest_paths. The documentation did not help very much in increasing the clarity. I think improving the definitions or, even adding examples would go a long way in making igraph more accessible.


You are right :slight_smile: We are already noticed the confusing naming ourselves and we’re planning to fix this in the next big API overhaul.

1 Like