Install Error

I am using R through Terra (essentially Jupyter notebook), R 4.0.3. I have tried to install igraph with the recommended code install.packages("igraph"), but keep receiving the non-zero exit error. I ultimately need igraph for a separate package that won’t work without igraph. Any suggestions for troubleshooting would be greatly appreciated.


Installing package into ‘/home/jupyter-user/notebooks/packages’
(as ‘lib’ is unspecified)

Warning message in install.packages("igraph"):
“installation of package ‘igraph’ had non-zero exit status”

I have also tried uninstalling and reinstalling igraph. The error says that igraph is not located in packages, but the package is visible when I navigate to /packages/


Removing package from ‘/home/jupyter-user/notebooks/packages’
(as ‘lib’ is unspecified)

Error in find.package(pkgs, lib): there is no package called ‘igraph’

1. remove.packages("igraph")
2. find.package(pkgs, lib)

I don’t exactly know the Terra environment, so I don’t know exactly from where they fetch their packages. Could you perhaps point me to a website that contains more information about this platform?

Without more details it is difficult to be of any help. Could you perhaps try to install with verbosity turned on, i.e. install.packages("igraph", verbose=TRUE)?

What exactly do you mean by “visible”, what is the exact filename / directory that you see?